So you logged into your Joomla Website, saw your control panel RS Firewall Update message and saw the following or something close to it:

You then went to update your Joomla Version from 2.5.9 to 2.5.11 and you got the error message:

The PHP allow_url_fopen setting is disabled. This setting must be enabled for the updater to work.

Solution:

If you had setup your RS Firewall correctly you should have a php.ini in your root folder AND in your administrator folder. Either case, just rename your php.ini to php.old and then attempt the Joomla update. This will enable you to update to Joomla 2.5.11 or beyond. Once the update is completed, go back and rename php.old to php.ini and then update your RS Firewall to the latest version.

Published in Joomla Support